Fonction si dans Excel

Vous souhaitez découvrir comment utiliser la fonction SI dans Excel ? Dans cet article vous trouverez plusieurs exemples pour mettre en pratique cette fonction primordiale.

Elle fait partie des fonctions les plus utilisées dans Excel. La fonction SI permet de renseigner une cellule selon des conditions établies entre deux hypothèses.

Comment utiliser la fonction SI dans Excel
Comment utiliser la fonction SI dans Excel

Par exemple, si le chiffre d’affaires de mon client dépasse 1 000 € mensuel la cellule promotion obtient une certaine valeur. Par contre, si le chiffre d’affaires est inférieur à 1 000 €, la cellule promotion obtient une valeur différente. Cette valeur peut-être un chiffre ou une chaîne de caractères.

A noter que cette formule résultat peut aussi être une fonction SI. Elles sont donc imbriquées l’une avec l’autre. Nous allons voir plusieurs exemples pour utiliser la fonction SI dans Excel. A la fin de cet article, vous comprendrez comment utiliser la fonction SI avec Excel.


Avant de commencer l’article, voici une question que je me pose :

Quelle est votre principale difficulté avec Excel ?


Sommaire de l’article

Dans un premier temps, nous allons découvrir comment insérer la fonction SI, il est possible d’insérer directement la formule dans une cellule, ou bien de fonctionner avec l’assistant des fonctions. Nous verrons les deux méthodes. Si vous connaissez déjà ces deux méthodes, vous pouvez passer directement à l’étape 3 dans le sommaire ci-dessous.

1. Fonction SI avec assistant
2. Fonction SI sans assistant
3. Expression dans les conditions
4. Comment utiliser la fonction SI
4.1. Combiner les conditions
4.2. Plus de deux conditions
4.3. Exemples d’utilisations simples
5. Conclusions

Prenons un premier type de tableau pour insérer la fonction SI. Nous avons une colonne indiquant les montants, celle-ci indique le montant dépensé par commande. L’objectif va être d’indiquer, selon le montant de la commande, si oui ou non le montant est suffisant pour que le client obtienne une remise. Pour cela, je vais déterminer deux conditions. Si la commande est inférieure à 40 euros, alors, il n’y a pas de remise, mais si la commande est supérieure à 40 euros alors il y a une remise de 5%.

La première chose que je vais faire est d’attribuer un nom à mes deux conditions, autrement dit, je vais renommer la cellule contenant le pourcentage de la remise. Si vous ne savez pas comment faire, il suffit de suivre cet article pour affecter un nom à une plage de données.

La capture ci-dessous montre les noms affectés aux conditions. La cellule contenant 0% se nomme « achat_sans_remise » et 5% se nomme « taux_remise ». Les noms attribués seront utilisés dans la fonction SI. Sur la capture, le cadre rouge de droite montre les remises, et le cadre de gauche montre les noms actuellement affectés à mes colonnes et à mes remises.

Fonction si dans Excel

1. Fonction SI avec assistant

Nous pouvons passer maintenant aux étapes suivantes résumées par la capture ci-dessous. On va insérer la fonction SI dans notre tableur avec l’assistant. Nous pouvons sélectionner la cellule (étape 1) dans laquelle on souhaite voir apparaître la remise pour la première commande.

Ensuite, on lance l’assistant de fonction « fx » (étape 2). Dans « recherchez une fonction », on indique le mot « si » (étape 3) qui va rechercher les fonctions en rapport avec le mot. Enfin dans la fenêtre du bas apparaît la fonction SI (étape 4), on la sélectionne et on valide.

Vous avez certainement constaté qu’il y a une colonne supplémentaire par rapport à la capture précédente, elle ne sera pas utilisée tout de suite, donc n’y prêtez pas attention pour le moment, c’est simplement que j’ai réalisé la procédure avec assistant après celle sans assistant.

Fonction SI

La fenêtre ci-dessous apparaît, c’est dans celle-ci qu’il faut construire notre fonction SI. Je l’ai découpée en trois étapes :

La première étape consiste à indiquer la condition qu’on souhaite mettre en place. Dans ce cas, il s’agit d’appliquer une remise de 5% si la commande est supérieure à 40 euros. Donc, on sélectionne la cellule D2, et on précise que la condition à tester sera : est-ce que D2 est supérieur à 40 ? Donc, on l’écrit de la manière suivante D2>40. On peut immédiatement voir la réponse à droite, il est inscrit =FAUX.

La seconde étape consiste à indiquer la valeur à faire apparaître si la condition est vraie. Il s’agit pour ma part d’une remise de 5% représentée par la cellule H3 sous le nom « taux_remise ». On constate à droite que 0,05 apparaît, il s’agit de la représentation de 5%.

La troisième et dernière étape consiste à indiquer la valeur à afficher lorsque la condition est fausse (ce qui est le cas de D2). Nous devons sélectionner la cellule H2, qui indique 0% de remise et qui porte le nom « achat_sans_remise ».

Le résultat apparaît en bas avant que nous validions, il sera de 0%. On constate également que la formule se construit au fur et à mesure que l’on sélectionne les informations dans la cellule E2.

Utiliser la fonction si Excel
Utiliser la fonction si Excel

On peut désormais faire glisser le résultat pour l’afficher dans toutes les cellules et voir les commandes qui auront une remise de 5%.

Résultat fonction SI

2. Fonction SI sans assistant

Il est également très simple d’utiliser la fonction SI dans Excel sans assistant. Pour cela, on sélectionne la cellule dans laquelle nous souhaitons faire apparaître le résultat. On réutilise les cellules contenant les montants des commandes, celles-ci sont actuellement en colonne C comme l’indique la capture ci-dessous. Nous allons donc insérer la formule en D2 pour tester la cellule C2.

La formule est la suivante =SI(condition;si_vrai;si_faux). La capture ci-dessous vous montre que lorsque vous remplissez votre formule, le contenu disponible apparaît dans un menu déroulant. La remise de 0% porte le nom « achat_sans_remise », si on tape « a » dans la formule le menu déroulant l’affiche sous son nom.

Test fonction SI Excel

La formule complète est la suivante =SI(C2>=40;taux_remise;achat_sans_remise). Autrement dit, si la cellule C2 (donc 34 €) est supérieure à 40 € alors on affiche « taux_remise » soit 5%, si C2 n’est pas supérieur à 40 € alors affiche « achat_sans_remise » soit 0%.

Plusieurs opérateurs sont disponibles pour comparer :

=Égal
<Inférieur
<=Inférieur ou égal
>Supérieur
>=Supérieur ou égal
<>Différent

Résultat formule SI Excel

Une fois la formule calculée, il suffit de la faire glisser dans les cellules en dessous pour obtenir les remises de toutes les commandes.

Fonction SI résultat dans Excel

3. Expression dans les conditions

Nous pouvons également créer des combinaisons de conditions, par exemple, dans la capture ci-dessous, une nouvelle colonne est apparue, celle-ci se nomme « Nouveau client », elle contient des 0 et des 1, le 0 correspond à un ancien client et le 1 correspond à un nouveau client.

Désormais, nous allons modifier notre formule pour que celle-ci ne prenne plus uniquement en compte le montant d’achat, mais également le fait que le client doit être nouveau pour avoir la remise. Pour avoir droit à 5% de remise, l’acheteur devra donc être un nouveau client qui achète pour plus de 40 euros (eh oui chez nous on ne donne pas des remises comme ça 😉 ).

Nous avons le choix entre plusieurs opérateurs, ET, OU, NON. Comme son nom l’indique ET indique que la condition 1 et la condition 2 doivent être valides. L’opérateur OU indique que la condition 1 ou la condition 2 doivent être valides. Enfin, NON inverse la condition, une condition vraie devient fausse.

Dans notre cas, nous allons utiliser l’opérateur ET, la formule sera donc : =SI(ET(D2>=40;C2=1);taux_remise;achat_sans_remise). Autrement dit si D2 est égal ou supérieur à 40 et C2 est égal à 1 alors la condition vraie donne 5%, sinon 0%.

Fonction SI avec conditions

En faisant glisser le résultat dans toutes les cellules ont obtient les commandes qui obtiennent 5%. Celles-ci sont encadrées en rouge sur la capture ci-dessous pour montrer qu’elles remplissent bien les deux conditions, avoir la valeur 1 en colonne C et être plus élevé que 40 en colonne D.

Modification Excel formule SI

4. Comment utiliser la fonction SI ?

Cette partie va permettre de découvrir comment utiliser la fonction SI dans Excel par le biais d’un scénario avec un tableau de client. Nous allons réutiliser les possibilités de la fonction SI que nous venons de présenter. Dans un premier temps, nous allons revoir la syntaxe pour utiliser la fonction SI par défaut (un petit rappel ne fait pas de mal). Cette syntaxe est la suivante :

=SI(Votre Condition ; contenu si vrai ; contenu si faux)

Dans le cas ci-dessous, nous avons une liste de 5 clients avec le chiffre d’affaires généré par chacun d’eux sur les six premiers mois de l’année. Nous allons créer une fonction SI simple.

Notre objectif va être d’appliquer une promotion sur les prochaines commandes de nos clients. Pour cela, ils doivent avoir dépassé les 60 000 € de chiffre d’affaires depuis le début de l’année (donc la somme des six mois). Ci-dessous, vous trouverez le tableau utilisé.

TELECHARGER FICHIER EXCEL FONCTION SI

Tableau pour le scénario avec la Fonction SI
Tableau pour le scénario avec la Fonction SI

Pour simplifier la formule, on renomme la valeur « OUI » dans le tableau, la valeur « NON » et la valeur « A STATUER ». Elles prennent respectivement les noms de « promo_oui », « promo_non » et « promo_a_statuer ». Si vous ne savez pas comment procéder, vous pouvez découvrir l’article pour affecter un nom à une plage de données (le lien se trouve en début d’article).

Pour appliquer notre première fonction SI et découvrir les clients qui peuvent obtenir la promotion on utilise la formule ci-dessous en B9 et on la faire glisser vers la droite.

=SI(B10>=60000;promo_oui;promo_non)

Voici le résultat final avec notre formule, trois de nos clients ont le droit à la promotion.

Utilisation de la fonction SI
Utilisation de la fonction SI

Ci-dessous nous allons voir quelques utilisations possibles avec les expressions. On peut toutes les combiner les unes avec les autres. Progressivement, on augmentera le niveau de complexité de la fonction SI.

4.1. Combiner les conditions

Nous venons de voir comment utiliser la fonction SI par défaut. Maintenant, allons un peu plus loin dans son utilisation. Pour cela, nous reprenons notre exemple tableau sur nos clients. Nous allons ajouter une condition pour l’obtention de la promotion.

Le client doit donc avoir un chiffre d’affaires supérieur 60 000 et une ancienneté supérieure à un an. La formule utilisée sera la suivante :

=SI(ET(B10>=60000;B2>=1);promo_oui;promo_non)

Comme on peut le voir sur notre exemple ci-dessus, notre client numéro 1 ne bénéfice plus de la prime alors qu’il a pourtant un le chiffre d’affaires requis. Mais il doit avoir dans notre cas deux conditions, le chiffre d’affaires et l’ancienneté supérieure à un an.

Conditions avec la fonction SI
Conditions avec la fonction SI

Mais vous pouvez très bien forcer la promo pour un client en particulier. Dans notre exemple, les clients 1, 3 et 5 n’ont pas le droit d’obtenir notre promotion. Mais notre client 5 à une ancienneté de 6 ans. C’est quelques choses que l’on peut récompenser. Certes le chiffre d’affaires n’est pas celui attendu, mais on sait que c’est un client qui revient toujours chez nous.

Nous allons donc forcer le destin et créer l’application automatique de la promotion. Vous le voyez dans la ligne « Auto ». Nous allons voir comment l’appliquer concrètement. Pour cela, on va utiliser

=SI(OU(B3<>"";ET(B10>=60000;B2>=1));promo_oui;promo_non)

Comme on peut le constater sur la capture ci-dessus, notre client fidèle à maintenant droit à la promotion. Concernant la lecture de la fonction SI. On peut la lire de la manière suivante :

Soit la cellule B3 est différente de vide, soit la cellule B10 est égale ou supérieure à 60000 et la cellule B2 est égale ou supérieure à 1. Si un des deux cas répond par « VRAI » on applique la promotion, sinon on ne l’applique pas. Cela permet à notre client 5 d’avoir la promotion, car la cellule « Auto » le concernant n’est pas vide.

Fonction SI pour activer la promotion automatique
Fonction SI pour activer la promotion automatique

4.2. Plus de deux possibilités de résultat avec la fonction SI

Vous avez remarquez que la fonction SI permet le choix entre seulement deux possibilités de résultat (application de la promotion ou non). Mais peut-être souhaitez-vous l’appliquer à trois solutions ?

C’est possible, avec un peu d’imagination. Pour cela, on va imbriquer une fonction SI dans la fonction SI. Nous allons donc utiliser la troisième possibilité pour l’application de notre fonction. Dans notre tableau, il s’agit de « A statuer ». On peut imaginer ce cas pour que l’application de la promotion ne soit pas automatique, et qu’une personne vérifie son application ou non.

=SI(B10<50000;promo_non ;SI(B10<60000 ;promo_a_statuer ;promo_oui))

On peut la lire de la manière suivante : si le chiffre d’affaires est inférieur à 50000 € pas de promotion, sinon si le chiffre d’affaires est inférieur à 60000 (mais supérieur à 50000 car la condition précédente à vérifiée) c’est à statuer, sinon on applique la promotion. Pour résumé, si le chiffre est sous 50000 pas de promo, entre 50000 et 60000 on fera au cas par cas et supérieur à 60000 on applique la promotion.

Fonction SI avec plusieurs solutions
Fonction SI avec plusieurs solutions

4.3. Exemple d’utilisation simple de la fonction

Ci-dessous, vous trouverez quatre formules qui montre le fonctionnement de la fonction SI lorsqu’elle est simplifiée :

=SI(B8>=C8 ;valeur_si_vrai ;valeur_si_faux)

Elle signifie, si le contenu de la cellule B8 est supérieur ou égale à celui de la cellule C8.

=SI(B11<> « Oui » ;valeur_si_vrai ;valeur_si_faux)

Si la cellule B11 ne contient pas la chaîne de caractère « Oui».

=SI(SOMME(B4 :B9)>60000 ; valeur_si_vrai ;valeur_si_faux)

Si la somme des cellules allant de B4 à B9 est supérieure à 60000.

=SI(SOMME(B4:B9)<>SOMME(C4 :C9) ; valeur_si_vrai ;valeur_si_faux)

Si la somme des cellules allant de B4 à B9 est différente de la somme des cellules allant de C4 à C9) .

5. Conclusion

Vous l’avez vu à travers cet article, il existe de nombreuses possibilités où l’on peut appliquer à la fonction SI dans Excel. En effet, les combinaisons des opérateurs vous donneront l’opportunité de faire jouer votre imagination pour adapter des fonctions à votre contexte.

C’est impossible de vous montrer l’ensemble des possibilités au sein d’un seul et même article ou alors celui-ci serait interminable. Vous pourrez au fur et à mesure du temps améliorer votre utilisation de cette fonction essentielle. Elle répondra à vos attentes dans la majorité des cas.

 

Articles en relation

2 commentaires

  1. Bonjour,

    Tout d’abord, merci pour votre partage !
    Je recherche comment insérer plus de 2 fonction SI dans une même cellule, pour le moment mon tableur prend uniquement les 2 premiers « SI » alors que j’en ai 2 après.

    Je travail avec 4 taux de remises selon 4 tranches de prix.

    Voici mon exemple selon les montants de commande :
    4000€ : 20%

    Peut-être que les signes supérieur inférieur que j’utilise dans ma formule sont faux :
    SI(Prix total2000;I2;SI(Prix total>3000;J2;SI(Prix total>4000;K2;))))

    H2 = 7%
    I2 = 12%
    J2 = 15%
    K2 = 20%

    Merci d’avance !

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

Fondateur

INSCRIVEZ-VOUS

Découvrez des astuces et conseils pour transformer votre site en réussite.

Merci. Vous allez recevoir un e-mail pour confirmer votre inscription. A très vite, Fabien

Pin It on Pinterest

Share This